Lycée   >   Terminale   >   Mathématiques complémentaires   >   La boucle for - spé maths complémentaires

La boucle for

  • Fiche de cours
  • Quiz
  • Profs en ligne
Objectifs
  • Comprendre une instruction itérative bornée.
  • Écrire une boucle bornée de la forme « Pour … allant de … à ... ».
Points clés
  • Dans un programme, on peut avoir besoin de répéter des actions similaires (calculs, affichages, etc.) un nombre connu de fois. On utilise alors une instruction appelée boucle bornée ou boucle for.
  • La boucle « for i in range(n) » prend toutes les valeurs entières de 0 à n – 1 inclus. La syntaxe pour écrire en langage Python une telle boucle est :
    for i in range (n):
        <Instructions>
  • La boucle « for i in range(n,m) » prend toutes les valeurs entières de n à m – 1 inclus. La syntaxe pour écrire en langage Python une telle boucle est :
    for i in range (n,m):
        <Instructions>
  • La boucle « for i in range(n,m,p) » prend toutes les valeurs entières de n à m – 1 inclus, avec un pas de p. La syntaxe pour écrire en langage Python une telle boucle est :
    for i in range (n,m,p):
        <Instructions>
Pour bien comprendre
  • Variables numériques
  • Affectation d’une variable
1. Boucle du type « for i in range(n) »
a. Principe

Dans un programme, on peut avoir besoin de répéter des actions similaires (calculs, affichages, etc.) un nombre connu de fois. On utilise alors une instruction appelée boucle bornée ou boucle for.

La boucle « for i in range(n) » prend toutes les valeurs entières de 0 à n – 1 inclus. La syntaxe pour écrire une telle boucle est :

Langage naturel Langage Python

Pour i allant de 0 à n 1
   <Instructions>
Fin Pour

for i in range(n):
   <Instructions>
Remarques
La variable i prend successivement toutes les valeurs entières de 0 à n – 1 inclus, soit n valeurs différentes.
Pour chaque valeur de i, la boucle « for i in range(n) » exécute les instructions.
b. Exemple
Langage naturel Langage Python

a ← 0
Pour i allant de 0 à 2
   a ← a + 2
Fin Pour


L’instruction conditionnelle permet d’ajouter, trois fois de suite, le nombre 2 à la variable a. On peut résumer les étapes dans un tableau :
 Valeurs prises par i   0 1 2
 Valeurs prises par a 0 2 4 6
Le résultat affiché est alors 6 (0 + 2 + 2 + 2).
Remarque
Voici les erreurs de saisie les plus classiques :
Oublier les deux points. Se tromper sur le choix de la valeur de n (ici i ne prend que les valeurs 0 et 1). Oublier ou effacer par mégarde la tabulation (indentation) de la ligne 3.
2. Boucle du type « for i in range(n,m) »
a. Principe
La boucle « for i in range(n,m) » prend toutes les valeurs entières de n à m – 1 inclus. La syntaxe pour écrire une telle boucle est :
Langage naturel Langage Python

Pour i allant de n à m – 1
   <Instructions>
Fin Pour

for i in range(n,m):
   <Instructions>
Remarques
La variable i prend successivement toutes les valeurs entières de n à m – 1 inclus, soit (m – n) valeurs différentes.
Pour chaque valeur de i, la boucle « for i in range(n,m) » exécute les instructions. Ces dernières sont donc exécutées (m – n) fois.
b. Exemple
Langage naturel Langage Python

a ← 0
Pour i allant de 4 à 6
   a ← a + i
Fin Pour


La boucle permet d’ajouter à la variable a les valeurs prises par la variable i, c'est-à-dire les nombres 4, puis 5 et enfin 6. On peut résumer les étapes dans un tableau :
 Valeurs prises par i   4 5 6
 Valeurs prises par a 0 4 9 15
Le résultat affiché est alors 15 (0 + 4 + 5 + 6).
Remarque
Les instructions « for i in range(n) » et « for i in range(0,n) » sont équivalentes.
3. Boucle du type « for i in range(n,m,p) »
a. Principe
La boucle « for i in range(n,m,p) » prend toutes les valeurs entières de n à m – 1 inclus, avec un pas de p. La syntaxe pour écrire une telle boucle est :
Langage naturel Langage Python

Pour i allant de n à m – 1 avec un pas de p
   <Instructions>
Fin Pour

for i in range(n,m,p):
   <Instructions>
Remarque
La variable i prend successivement toutes les valeurs entières de n, n + p, n + 2p, n + 3p, etc. à m – 1.
b. Exemple
Langage naturel Langage Python

a ← 0
Pour i allant de 1 à 5 avec un pas de 2
   a ← a + i
Fin Pour


La boucle permet d’ajouter à la variable a les valeurs prises par la variable i, c'est-à-dire les nombres 1, puis 3 et enfin 5. On peut résumer les étapes dans un tableau :
 Valeurs prises par i   1 3 5
 Valeurs prises par a 0 1 4 9
Le résultat affiché est alors 9 (0 + 1 + 3 + 5).
Remarque
Les instructions « for i in range(n) » et « for i in range(0,n,1) » sont équivalentes.

Comment as-tu trouvé ce cours ?

Évalue ce cours !

 

Question 1/5

La médiane de 6 notes est 13. Cela signifie que :

Question 2/5

On a obtenu la série statistique suivante :

Combien vaut la médiane ?

Question 3/5

On a obtenu la série ci-dessous :

Quelle est la médiane de cette série ?

Question 4/5

On a relevé les tailles en cm des élèves d’une classe :

 

Parmi les propositions suivantes, laquelle est vraie ?

Question 5/5

Les notes en français de deux classes littéraires sont données dans le tableau suivant :

Quelle est la note médiane ?

Vous avez obtenu75%de bonnes réponses !

Reçois l’intégralité des bonnes réponses ainsi que les rappels de cours associés

Une erreur s'est produite, veuillez ré-essayer

Consultez votre boite email, vous y trouverez vos résultats de quiz!

Découvrez le soutien scolaire en ligne avec myMaxicours

Le service propose une plateforme de contenus interactifs, ludiques et variés pour les élèves du CP à la Terminale. Nous proposons des univers adaptés aux tranches d'âge afin de favoriser la concentration, encourager et motiver quel que soit le niveau. Nous souhaitons que chacun se sente bien pour apprendre et progresser en toute sérénité ! 

Fiches de cours les plus recherchées

Mathématiques complémentaires

Rappels sur les suites géométriques et notion de limite

Mathématiques complémentaires

La somme des termes d'une suite géométrique

Mathématiques complémentaires

Définitions et notations ensemblistes

Mathématiques complémentaires

Rappels sur les suites numériques : définition, génération, notation

Mathématiques complémentaires

Espérance et variance d'une loi à densité

Mathématiques complémentaires

La notion de limite de suite

Mathématiques complémentaires

Les listes en Python : création et manipulation

Mathématiques complémentaires

Les listes en Python : application aux probabilités et statistiques

Mathématiques complémentaires

Les listes en Python : application aux suites et aux fonctions

Mathématiques complémentaires

Les listes en Python : applications en géométrie analytique