L'instruction if - spé maths complémentaires - Maxicours

L'instruction if

Objectifs
  • Comprendre une instruction conditionnelle.
  • Écrire une instruction comportant une ou plusieurs conditions.
Points clés
  • Dans un programme informatique, il arrive que la réponse attendue dépende d’une ou de plusieurs conditions. On utilise alors des instructions conditionnelles.
  • La syntaxe pour écrire en langage Python une instruction conditionnelle à une condition est :
    if <condition>:
          <instructions>
  • La syntaxe pour écrire en langage Python une instruction conditionnelle à deux conditions est :
    if <condition>:
          <instructions>
    else:
          <instructions>
  • La syntaxe pour écrire en langage Python une instruction conditionnelle à trois conditions est :
    if <condition>:
          <instructions>
    elif <condition>:
          <instructions>
    else:
          <instructions>
Pour bien comprendre
  • Variables numériques
  • Variables de type booléen
  • Affectation d’une variable
1. Instruction conditionnelle à une condition
a. Principe
Dans un programme informatique, il arrive que la réponse attendue dépende d’une ou de plusieurs conditions. On utilise alors des instructions conditionnelles.

La syntaxe pour écrire une instruction conditionnelle à une condition est :

Langage naturel Langage Python

Si <condition> alors
   <Instructions>
Fin Si

if <condition>:
   <Instructions>
Remarques
Dans Python, on ne traduit pas le mot « alors ». Il est modélisé par « : ».
Il y a une tabulation (un grand espace) avant l’instruction. Elle est souvent appelée l’indentation. Cette tabulation est créée automatiquement dans la console, mais il arrive qu’elle soit supprimée par mégarde. La commande ne fonctionne alors plus.
b. Exemple
Langage naturel Langage Python

Si n 3 alors
   n ← n + 4
Fin Si

L’instruction conditionnelle permet d’ajouter 4 à tous les nombres inférieurs ou égaux à 3.
Les nombres strictement supérieurs à 3 ne sont pas modifiés.
Remarque
Voici les erreurs de saisie les plus classiques :
Oublier les deux points. Écrire « then » à la place des deux points. Oublier ou effacer par mégarde la tabulation (indentation) de la ligne 2.
Avec ces erreurs, la commande ne fonctionne plus.
2. Instruction conditionnelle à deux conditions
a. Principe
La syntaxe pour écrire une instruction conditionnelle à deux conditions est :
Langage naturel Langage Python

Si <condition> alors
   <Instructions>
sinon
   <Instructions>
Fin Si

if <condition>:
   <Instructions>
else:
   <Instructions>
Remarque
Il ne faut pas oublier les tabulations et les « : ».
b. Exemple
Langage naturel Langage Python

Si n 3 alors
   n ← n + 4
Sinon
   n ← n – 4
Fin Si


L'instruction conditionnelle permet :
  1. d'ajouter 4 à tous les nombres inférieurs ou égaux à 3 ;
  2. de soustraire 4 à tous les nombres strictement supérieurs à 3.
3. Instruction conditionnelle à trois conditions
a. Principe
La syntaxe pour écrire une instruction conditionnelle à trois conditions est :
Langage naturel Langage Python

Si <condition> alors
   <Instructions>
sinon
   Si <conditions> alors
      <Instructions>
   sinon
      <Instructions>
   Fin Si
Fin Si

if <condition>:
   <Instructions>
elif <condition>:
   <Instructions>
else:
   <Instructions>
b. Exemple
Langage naturel Langage Python

Si n 3 alors
   n ← n + 4
Sinon
   si n 5 alors
      n ← n 4
   sinon
      n ← n 8
   Fin Si
Fin Si


L'instruction conditionnelle permet :
  1. d'ajouter 4 à tous les nombres inférieurs ou égaux à 3 ;
  2. de soustraire 4 à tous les nombres strictement supérieurs à 3 et inférieurs ou égaux à 5 ;
  3. de soustraire 8 à tous les nombres strictement supérieurs à 5.
4. Exemple d'une instruction conditionnelle avec plus de trois conditions

On peut ajouter autant de « elif » que nécessaire.

Exemple
Langage naturel Langage Python

Si n 3 alors
   n ← n + 4
Sinon
   si n 5 alors
      n ← n 4
   Sinon
      si n ≤ 7 alors
         n ← n 8
      sinon
         n ← n 12
      Fin Si
   Fin Si
Fin Si


L'instruction conditionnelle permet :
  1. d'ajouter 4 à tous les nombres inférieurs ou égaux à 3 ;
  2. de soustraire 4 à tous les nombres strictement supérieurs à 3 et inférieurs ou égaux à 5 ;
  3. de soustraire 8 à tous les nombres strictement supérieurs à 5 et inférieurs ou égaux à 7 ;
  4. de soustraire 12 à tous les nombres strictement supérieurs à 7.

Vous avez déjà mis une note à ce cours.

Découvrez les autres cours offerts par Maxicours !

Découvrez Maxicours

Comment as-tu trouvé ce cours ?

Évalue ce cours !

 

quote blanc icon

Découvrez Maxicours

Exerce toi en t’abonnant

Fiches de cours les plus recherchées

Mathématiques complémentaires

La boucle while - spé maths complémentaires

Mathématiques complémentaires

Les calculs - Terminale

Mathématiques complémentaires

Les fonctions simples - Terminale

Mathématiques complémentaires

Les fonctions complexes - Terminale

Mathématiques complémentaires

Les expériences aléatoires

Mathématiques complémentaires

La boucle for - spé maths complémentaires

Mathématiques complémentaires

La somme des termes d'une suite géométrique

Mathématiques complémentaires

Définitions et notations ensemblistes

Des profs en ligne

  • 6j/7 de 17 h à 20 h
  • Par chat, audio, vidéo
  • Sur les matières principales

Des ressources riches

  • Fiches, vidéos de cours
  • Exercices & corrigés
  • Modules de révisions Bac et Brevet

Des outils ludiques

  • Coach virtuel
  • Quiz interactifs
  • Planning de révision

Des tableaux de bord

  • Suivi de la progression
  • Score d’assiduité
  • Un compte Parent

Inscrivez-vous à notre newsletter !

Votre adresse e-mail sera exclusivement utilisée pour vous envoyer notre newsletter. Vous pourrez vous désinscrire à tout moment, à travers le lien de désinscription présent dans chaque newsletter. En savoir plus sur notre politique de confidentialité